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1. Working with PSpice: 
 
PSpice is a circuit simulator. It uses the Kirchhoff’s laws and the iv-relation of the used 
components to calculate the electric potentials of all nodes and the electric current 
through all branches. You can consider PSpice to be the software version of the 
electronic breadboard you have been using in the first two labs.  
 
Although PSpice can be used to solve for a lot of different problems, we will use it 
mainly for: 

1. Bias Point analysis: In this mode the program calculates the currents through the 
branches and the electric potentials of the nodes of your electronic circuit.  

2. Transient analysis: In this mode the program calculates the time response of a 
circuit when excited by a by you defined input signal. This can be a sine wave, a 
square wave, a triangular wave, a pulse signal, or any piece-wise linear signal.  

3. AC-Sweep analysis: In this mode the program calculates the frequency response 
of a circuit. The input will be sine wave that is scanned over a by you defined 
frequency range. The output can for example be the amplitude of the output 
voltage, the phase of the output voltage, etc. 

 
For all three modes you have to start of with defining your circuit. You do this with the 
program Orcad-Capture. You define the circuit by drawing it on your computer screen. 
You can use component libraries that contain the symbols for almost all electronic 
components that are on the market. After you dropped the components on your 
worksheet, you have to make the electrical connections between them.  
Once you have defined your circuit you have to define the simulation profile. This means 
you have to tell the program whether or not you would like to do a bias point analysis, a 
transient analysis, or an AC-sweep analysis. Depending on the mode, you need to provide 
the program with information on how accurate and in what data range you would like it 
to do the simulation.  
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2. Bias Point Analysis 
 
This section describes how to use Orcad Capture to create the simple voltage divider 
circuit  of  Lab 1-4, shown in Fig. 1. 

 
Fig. 1: Voltage Divider of Lab 1-4 with 10K load resistor. Bias point analysis 

 
To create a new PSpice project 

1. From the Windows Start menu, choose the Orcad 
program folder and then the Capture shortcut to 
start Capture. 

2. In the Project Manager, from the File menu, point to 
New and choose Project. 

3. Select Analog or Mixed-Signal Circuit Wizard. 
4. In the Name text box, enter the name of the project 

(LAB14). 
5. Use the Browse button to select the location for the 

project files, then click OK. 
6. In the Create PSpice Project dialog box, select 

Create a blank project. 
7. Click OK. 
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No special libraries need to be configured at this time. A 
new page will be displayed in Capture and the new project 
will be configured in the Project Manager. 
 
To place the voltage sources 

1. In Capture, switch to the schematic page editor. 
2. From the Place menu, choose Part to display the 

Place Part dialog box. 
3. Add the library for the parts you need to place: 

a. Click the Add Library button. 
b. Select SOURCE.OLB (from the PSpice 

library) and click Open. 
4. In the Part text box, type VDC. 
5. Click OK. 
6. Move the pointer to the correct position on the 

schematic page (see Fig. 1) and click to place the 
first part. 

7. Right-click and choose End Mode to stop placing 
parts. 

 
To place the Resistors 

1. From the Place menu, choose Part to display the 
Place Part dialog box. 

Note: There are two sets of library files 
supplied with Capture and PSpice. The 
standard schematic part libraries are 
found in the directory Capture\Library. 
The part libraries that are designed for 
simulation with PSpice are found in the 
sub-directory Capture\Library\PSpice. 
In order to have access to specific 
parts, you must first configure the 
library in Capture using the Add 
Library function. 

2. Add the library for the parts you need to place: 
a. Click the Add Library button. 
b. Select ANALOG.OLB (from the PSpice 

library) and click Open. 
3. In the Part text box, type R to display a list of 

resistors. 
4. Select R from the Part List and click OK. 
5. Press r to rotate the resistor to the correct 

orientation. 
6. Click to place the first resistor (R1), and then click 

to place the second (R2) and the third resistor (R3). 
7. Right-click and choose End Mode to stop placing 

parts. 
 
To move the text associated with any 
component: 

1. Click the text to select it, and then drag the text to a 
new location. 
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To place the other parts 
1. From the Place menu, choose Part to display the 

Place Part dialog box. Add the library for the parts 
you need to place.  

2. Follow similar steps as described for the resistor to 
place the other parts of your circuit.  

3. To place the off-page connector parts 
(OFFPAGELEFT-R), click the Place Off-Page 
Connector button on the tool palette. 

4. Add the library for the parts you need to place: 
a. Click the Add Library button. 
b. Select CAPSYM.OLB (from the Capture 

library) and click Open.  
5. Place the off-page connector parts according to Fig. 

1. 
6. To place the ground parts (0), click the GND button 

on the tool palette. 
7. Add the library for the parts you need to place: 

a. Click the Add Library button. 
b. Select SOURCE.OLB (from the PSpice 

library) and click Open. 
8. Place the ‘0’ ground part from SOURCE .OLB as 

shown in Fig. 1. 
 

To connect the parts 
1. From the Place menu, choose Wire to begin wiring 

parts. The pointer changes to a crosshair. 
2. Click the connection point (the very end) of the pin 

on the off-page connector at the input of the circuit. 
3. Click the nearest connection point of the input 

resistor R1. 
4. Connect the other end of R1 to R2 and R3: 

a. Click the connection point of R1. 
b. Move the cursor straight down and click the 

connection point of R2.  
c. Click the wire between the resistors and 

draw the cursor to the right and click the 
connection point of R3. 

5. Continue connecting parts until the circuit is wired 
as shown in Fig. 1 on page 2. 

 
To assign names (labels) to the nets 

1. From the Place menu, choose Net Alias to display 
the Place Net Alias dialog box. 
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2. In the Name text box, type Vout.  
3. Click OK. 
4. Place the net alias on any segment of the wire that 

connects R1, R2, and R3. The lower left corner of the 
net alias must touch the wire. 

5. Right-click and choose End Mode to quit the Net 
Alias function. 

 
 
To assign names (labels) to the off-page 
connectors 
Label the off-page connectors as shown in Fig. 1 on page 2. 

1. Double-click the name of an off-page connector to 
display the Display Properties dialog box. 

2. In the Name text box, type the new name. 
3. Click OK. 
4. Select and relocate the new name as desired. 

 
To assign names to the parts 

1. Double-click the VDC part to display the Parts 
spreadsheet. 

2. Click in the first cell under the Reference column. 
3. Type in the new name Vin. 
4. Click Apply to update the changes to the part, and 

then close the spreadsheet. 
5. Continue naming the remaining parts until your 

schematic looks like Fig. 2 on page 2. 
 
To change the values of the parts 

A more efficient way to change the names, 
values and other properties of several parts 
in your design is to use the Property Editor, 
as follows: 
1 Select all of the parts to be modified by 
pressing Ctrl and clicking each part. 
2 From the Edit menu, choose Properties. 
The Parts Spreadsheet appears. 
Change the entries in as many of the cells
as needed, and then click Apply to update
all of the changes at once. 

1. Double-click the voltage label (0V) on V1 to 
display the Display Properties dialog box. 

2. In the Value text box, type 15V. 
3. Click OK. 
4. Continue changing the Part Value properties of the 

parts until all the parts are defined as in Fig. 1 on 
page 2. 

Your schematic page should now have the same parts, 
wiring, labels, and properties as Fig. 1 on page 2. 
 
To save your design 

1. From the File menu, choose Save.  
 



Applied Electronics, Southwest Texas State University, 6, 13 

Running a Bias Point Analysis 
When you perform a simulation, PSpice generates an 
output file (*.OUT). 
While PSpice is running, the progress of the simulation 
appears and is updated in the PSpice simulation output 
window. 
 

1. In Capture, switch to LAB14.OPJ in the schematic 
page editor. 

2. From the PSpice menu, choose New Simulation 
Profile to display the New Simulation dialog box. 

3. In the Name text box, type Bias. 
4. From the Inherit From list, select None, then click 

Create. The Simulation Settings dialog box appears. 
5. From the Analysis type list, select Bias Point. 
6. Click OK to close the Simulation Settings dialog 

box.  
 
To simulate the circuit from within 
Capture 

1. From the PSpice menu, choose Run. PSpice 
simulates the circuit and calculates the bias point 
information. 

 
Results of Bias Point Simulation 
The results of the bias point simulation are displayed in the 
simulation output file or can be displayed on the circuit in 
the schematic editor. 
 
To view the simulation output file 
The simulation output file acts as an audit trail of the 
simulation. This file optionally echoes the contents of the 
circuit file as well as the results of the bias point 
calculation. If there are any syntax errors in the netlist 
declarations or simulation commands, or anomalies while 
performing the calculation, PSpice writes error or warning 
messages to the output file. 

1. In PSpice, from the View menu, choose Output File.  
2. When finished, close the window. 

 
PSpice measures the current through a two terminal device 
into the first terminal and out of the second terminal. For 
voltage sources, current is measured from the positive 
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terminal to the negative terminal; this is opposite to the 
positive current flow convention and results in a negative 
value in the output file. 
 
To view the simulation output file 
To view the simulation results in the schematic page editor, 
click the V, I, and or W button in the toolbar at the top of 
the screen. This will respectively show the node voltages, 
the branch currents, and/or the power dissipated in the 
branches. 
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3. Transient Analysis 
 
This example shows how to run a transient analysis on the RC circuit of lab 2.1. This 
requires adding a time-domain voltage stimulus as shown in Fig. 2. 
 

 
Fig 2: Transient analysis on a simple RC-circuit. 

 
 
To place a time-domain voltage stimulus 

1. Start a new project (see page 2). 
2. Build the circuit as shown in Fig. 2 by using the 

techniques discussed in section 2.  
3. From the Place menu in the schematic editor choose 

Part to display the Place Part dialog box.   
4. Add the library for the parts you need to place: 

a. Click the Add Library button. 
b. Select SOURCESTM.OLB (from the PSpice 

library) and click Open. 
5. In the Part text box, type VSTIM and place the part 

in the schematic editor. 
6. Once you are done with building the circuit of Fig. 

2, choose Save to save the design. 
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To set up the stimulus 

1. Select the VSTIM part (V2). 
2. From the Edit menu, choose PSpice Stimulus. The 

New Stimulus dialog box appears. 
3. In the New Stimulus dialog box, type 

INPUTLAB21. 
4. Click Pulse, and then click OK. 
5. In the Pulse Attributes dialog box, set the 

properties, including: 
a. Amplitude = 1 volt 
b. Pulse width = 1 ms 
c. Period = 2 ms 
d. Rise time = 2 ns 
e. Fall time = 2 ns 
f. Time delay = 0 s 

6. Click Apply to view the waveform. A square wave 
will be displayed in the stimulus editor.  

7. Click OK. 
8. From the File menu, choose Save to save the 

stimulus information. Click Yes to update the 
schematic. 

9. From the File menu, choose Exit to exit the 
Stimulus Editor. 

 
To set up and run the transient analysis 

1. From Capture’s PSpice menu, choose New 
Simulation Profile. The New Simulation dialog box 
appears. 

2. In the Name text box, type Lab21TimeResponse. 
3. From the Inherit From list, select None, then click 

Create. The Simulation Settings dialog box appears. 
4. Click the Analysis tab.  

Note: The internal time step is 
different from the Print Step value. 
Print Step controls how often 
optional text format data is written 
to the simulation output file 
(*.OUT). 

5. From the Analysis list, select Time Domain 
(Transient) and enter the time interval over which 
the computer should calculate the time response: 

a. TSTOP = 6ms 
b. Start saving data after = 0 s. 

6. Click OK to close the Simulation Settings dialog 
box. 

7. From the PSpice menu, choose Run to perform the 
analysis. 

 
PSpice uses its own internal time steps for 
computation. The internal time step is adjusted 
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according to the requirements of the transient 
analysis as it proceeds. PSpice saves data to the 
waveform data file for each internal time step. 
 

 
Fig. 3: Output data of transient analysis. 

 
To display the charge and discharge 
curve of the capacitor: 

1. From the schematic editor choose Markers and 
select Voltage. 

2. Place the first marker by clicking the wire 
connected to Vin. 

3. Place the second marker by clicking the wire that 
connects the resistor with the capacitor. Go now 
back to the PSpice window. You should see a red 
square curve reflecting the input signal, and a green 
curve reflecting the output voltage of the lowpass 
filter.  

4. Another method to visualize those curves is via the 
Trace menu of PSpice. Choose Add Trace. 

5. In the trace list, select V(In) and any other node of 
who you like the voltage to be displayed.  

6. Click OK to display the traces. 
7. From the Tools menu, choose Options to display the 

Probe Options dialog box. 
8. In the Use Symbols frame, click Always if it is not 

already enabled. Click OK. 
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4. AC Sweep Analysis 
 
The AC sweep analysis in PSpice is a linear (or small signal) frequency domain analysis 
that can be used to observe the frequency response of any circuit at its bias point. It 
requires placing an AC Voltage Source.
In this example, you will set up the low pass circuit for AC analysis by substituting an 
AC voltage source for a stimulus voltage source (see Fig. 4) and by setting up the AC 
sweep parameters. 
 

 
Fig. 4: AC analysis on low pass filter. 

 
To change Vin to enable a calculation of 
the frequency response. 

1. Select the VSTIM voltage source of section 3, and 
press D to remove the part from the schematic page. 

2. From the Place menu, choose Part. 
3. In the Part text box, type VAC (from the PSpice 

library SOURCE.OLB) and click OK. 
4. Place the AC voltage source on the schematic page, 

as shown in Fig. 4. 
5. Double-click the VAC part (0V) to display the Parts 



Applied Electronics, Southwest Texas State University, 12, 13 

spreadsheet. 
6. Change the ACMAG cell to 1V. 
7. Click Apply to update the changes and then close 

the spreadsheet. 
 
To set up and run the AC sweep simulation 

1. From Capture’s PSpice menu, choose New 
Simulation Profile. Note PSpice simulation is not case-

sensitive, so both M and m can be used
as “milli,” and MEG, Meg, and meg can
all be used for “mega.” However,
waveform analysis treats M and m as
mega and milli, respectively. 

2. In the Name text box, enter AC Sweep, then click 
create. The Simulation Settings dialog box appears. 

3. Click the Analysis tab. 
4. From the Analysis type list, select AC Sweep/Noise 

and enter the frequency range, i.e. 10 Hz through 
1000000 Hz. 

5. Click OK to close the Simulation Settings dialog 
box. 

6. From the PSpice menu, choose Run to start the 
simulation. PSpice performs the AC analysis. 

 
To add markers for waveform analysis 

1. From Capture’s PSpice menu, point to Markers, 
point to Advanced, and then choose db Magnitude 
of Voltage. 

2. Place one Vdb marker on the Vout net, and then 
place another on the Vin net. 

3. From the File menu, choose Save to save the 
design. 

 
AC sweep analysis results 
PSpice displays the dB magnitude (20log10) of the voltage 
at the marked nets, Vout and Vin, in a Probe window as 
shown in Fig. 5 below. Vdb has a lowpass response due to 
the capacitor C1 to the ground. Because AC is a linear 
analysis and the input voltage was set to 1V, the output 
voltage is the same as the gain (or attenuation) of the 
circuit.  
 
To introduce a 2nd Y-axis: 

1. Click the trace name Vin to select the trace. 
2. From the Edit menu, choose Cut. 
3. From the Plot menu, choose Add Y Axis. 
4. From the Edit menu, choose Paste. The Bode plot 

appears, as shown in Fig. 5. 
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Fig. 5: Bode Plot for the lowpass filter of Fig. 4. 

 
To display a Bode plot of the output voltage, including phase 

1. From Capture’s PSpice menu, point to Markers, 
point to Advanced and choose Phase of Voltage. 

2. Place a Vphase marker on the output next to the 
Vdb marker. 

3. Delete the Vdb marker on Vin. 
4. Switch to PSpice. In the Probe window, the gain 

and phase plots both appear on the same graph with 
the same scale. 

 
 

 
 


